Collapso not displaying right in IE7

Expanding / Collapsing, search engine friendly, Section menu.
Post Reply
budgetbumps
Posts: 7
Joined: Thu Jul 12, 2007 3:16 pm

Collapso not displaying right in IE7

Post by budgetbumps » Thu Jul 12, 2007 3:25 pm

I've just installed the collapso menu on http://www.jesterstrickbits.co.uk

I've used the rollover boxes style

It displays fine in Firefox...but it looks untidy in IE7 when moving down the levels..

Most obvious when going through the "Make and model" sections which are 3 layers deep.

Why is it failing like this?
I'd never noticed on my other site because I use the standard version, not the rollover boxes.

The only thing I've done in the css is change a couple of colours and make the boxes shallower so the list takes up less room vertically.

Any ideas?

norman
Site Admin
Posts: 1233
Joined: Sat Feb 07, 2004 9:55 pm

Post by norman » Fri Jul 13, 2007 11:26 pm

I'm flummoxed. I see the fault on your site but when I look at others - e.g. - http://www.drillpine.biz/v8collapso5/ - everything's fine.

CSS isn't my strong point. I've never had time to start learning about it other than the basics.

If you know anyone who may be able to help it might be worth asking there.
Norman

budgetbumps
Posts: 7
Joined: Thu Jul 12, 2007 3:16 pm

Post by budgetbumps » Fri Jul 13, 2007 11:39 pm

no probs, Norman
I'll ask around

Thanks

norman
Site Admin
Posts: 1233
Joined: Sat Feb 07, 2004 9:55 pm

Post by norman » Sat Jul 14, 2007 8:48 am

Found it! Fixed it! But I don't know why it fixes it!!!

In your overall layout, you have as tyhe very first line

Code: Select all

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
If I change it to

Code: Select all

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">
Then it's fine in IE, FF and Opera.
Norman

budgetbumps
Posts: 7
Joined: Thu Jul 12, 2007 3:16 pm

Post by budgetbumps » Sat Jul 14, 2007 8:51 am

excellent Norman, thank you!
I'll change that and see how it goes
:D

budgetbumps
Posts: 7
Joined: Thu Jul 12, 2007 3:16 pm

Post by budgetbumps » Sat Jul 14, 2007 1:23 pm

Bizarre!
Strange but true...not sure why it works but it does!
Thanks again Norman!

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest